Peter's Smokes UVA - 10346|Solution 2

Peter’s Smokes UVA – 10346|Solution

Peter’s Smokes UVA – 10346|Solution

Peter has n cigarettes. He smokes them one by one keeping all the butts. Out of k > 1 butts he can
roll a new cigarette.
How many cigarettes can Peter have?

Input


Input is a sequence of lines. Each line contains two integer numbers giving the values of n and k. The
input is terminated by end of file.

Output

For each line of input, output one integer number on a separate line giving the maximum number of
cigarettes that Peter can have.

Sample Input

4 3
10 3
100 5

Sample Output

5
14
124

Solve Code

#include<stdio.h>


int main()
{
    long int n,k,r,get;
    while(scanf("%ld%ld",&n,&k)==2)
    {
        r=0;
        
        r=n+n/k;
        get=n/k+n%k;
        
        while(get>=k)
        {
            r=r+get/k;
            get=get/k+get%k;
        }
        printf("%ld\n",r);
    }
   
   
   
    return 0;
}