Distance Between Two Points
Adapted by Neilor Tonin, URI Brazil | Timelimit: 1
Read the four values corresponding to the x and y axes of two points in the plane, p1 (x1, y1) and p2 (x2, y2) and calculate the distance between them, showing four decimal places after the comma, according to the formula:

Distance =
Input
The input file contains two lines of data. The first one contains two double values: x1 y1 and the second one also contains two double values with one digit after the decimal point: x2 y2.
Output
Calculate and print the distance value using the provided formula, with 4 digits after the decimal point.
Input Sample | Output Sample |
1.0 7.0 5.0 9.0 | 4.4721 |
-2.5 0.4 12.1 7.3 | 16.1484 |
2.5 -0.4 -12.2 7.0 | 16.4575 |
Solution
#include <stdio.h>
#include<math.h>
int main()
{
double x1,y1,x2,y2,p;
scanf("%lf %lf",&x1,&y1);
scanf("%lf %lf",&x2,&y2);
p=sqrt(((x2-x1)*(x2-x1))+((y2-y1)*(y2-y1)));
printf("%.4lf\n",p);
return 0;
}
- How to Use URI Online Judge to Improve Your Coding Skills and Boost Your Career
- BEST FREE GIFT CARD GENERATOR in 2022
- উইন্ডোজ 11 এসে গেল, নজরকাড়া লুক, তাক লাগানো ফিচার্স!
- URI 2694 Solved by C programming
- URI Online Solve | 1957 Converting to Hexadecimal- Solution
- Android custom toolbar Android Studio | Android Tutorial
- URI Online Judge | 1040 Solution | Average 3
- URI Online Judge | 1038 Solution |Snack
- URI Online Judge | 1037 Solution | Interval
- URI Online Judge | 1036 Solution | Bhaskara’s Formula
- URI Online Judge Solution| 1035 Selection Test 1
- URI Online Judge Solution| 1021 Banknotes and Coins
- URI Online Judge Solution| 1020 Age in Days
- URI Online Judge Solution| 1019 Time Conversion
- URI Online Judge Solution| 1018 Banknotes