URI Online Judge solve 1037

URI Online Judge | 1037 Solution | Interval

Interval

Adapted by Neilor Tonin, URI  Brazil | Timelimit: 1

You must make a program that read a float-point number and print a message saying in which of following intervals the number belongs: [0,25] (25,50], (50,75], (75,100]. If the read number is less than zero or greather than 100, the program must print the message “Fora de intervalo” that means “Out of Interval”.

The symbol ‘(‘ represents greather than. For example:
[0,25] indicates numbers between 0 and 25.0000, including both.
(25,50] indicates numbers greather than 25 (25.00001) up to 50.0000000.

Input

The input file contains a floating-point number.

Output

The output must be a message like following example.

Input SampleOutput Sample
25.01Intervalo (25,50]
25.00Intervalo [0,25]
100.00Intervalo (75,100]
-25.02Fora de intervalo

Source Code

#include <stdio.h>


int main()
{
   float s;
   scanf("%f",&s);

   if(s>=0&&s<=25.0000){printf("Intervalo [0,25]\n");}
   else if (s>=25.00001&&s<=50.0000000){printf("Intervalo (25,50]\n");}
   else if (s>=50.000001&&s<=75.0000000){printf("Intervalo (50,75]\n");}
   else if (s>=75.000000001&&s<=100.000000000){printf("Intervalo (75,100]\n");}
   else{

    printf("Fora de intervalo\n");


   }
    return 0;
}