Average 3
Adapted by Neilor Tonin, URI Brazil | Timelimit: 1
Read four numbers (N1, N2, N3, N4), which one with 1 digit after the decimal point, corresponding to 4 scores obtained by a student. Calculate the average with weights 2, 3, 4 e 1 respectively, for these 4 scores and print the message “Media: ” (Average), followed by the calculated result. If the average was 7.0 or more, print the message “Aluno aprovado.” (Approved Student). If the average was less than 5.0, print the message: “Aluno reprovado.” (Reproved Student). If the average was between 5.0 and 6.9, including these, the program must print the message “Aluno em exame.” (In exam student).
In case of exam, read one more score. Print the message “Nota do exame: “ (Exam score) followed by the typed score. Recalculate the average (sum the exam score with the previous calculated average and divide by 2) and print the message “Aluno aprovado.” (Approved student) in case of average 5.0 or more) or “Aluno reprovado.” (Reproved student) in case of average 4.9 or less. For these 2 cases (approved or reproved after the exam) print the message “Media final: “ (Final average) followed by the final average for this student in the last line.
Input
The input contains four floating point numbers that represent the students’ grades.
Output
Print all the answers with one digit after the decimal point.
Input Sample | Output Sample |
2.0 4.0 7.5 8.0 6.4 | Media: 5.4 Aluno em exame. Nota do exame: 6.4 Aluno aprovado. Media final: 5.9 |
2.0 6.5 4.0 9.0 | Media: 4.8 Aluno reprovado. |
9.0 4.0 8.5 9.0 | Media: 7.3 Aluno aprovado. |
Source Code
#include <stdio.h>
int main() {
float N1 ,N2 , N3 , N4 ,Media , extra ,final ;
scanf("%f %f %f %f",&N1,&N2,&N3,&N4);
Media=((N1*2)+(N2*3)+(N3*4)+(N4*1))/10;
printf("Media: %.1f\n",Media);
if (Media>7.0)
{
printf("Aluno aprovado.\n");
}
else if(Media<5.0)
{
printf("Aluno reprovado.\n");
}
else if(Media<6.9 && Media >= 5.0)
{
printf("Aluno em exame.\n");
scanf("%f",&extra);
printf("Nota do exame: %.1f\n",extra);
final=(Media+extra)/2;
if(final >= 5.0)
{
printf("Aluno aprovado.\n");
}
else if (final<=4.9)
{
printf("Aluno reprovado.\n");
}
printf("Media final: %.1f\n",final);
}
return 0;
}
- How to Use URI Online Judge to Improve Your Coding Skills and Boost Your Career
- BEST FREE GIFT CARD GENERATOR in 2022
- উইন্ডোজ 11 এসে গেল, নজরকাড়া লুক, তাক লাগানো ফিচার্স!
- URI 2694 Solved by C programming
- URI Online Solve | 1957 Converting to Hexadecimal- Solution
- Android custom toolbar Android Studio | Android Tutorial
- URI Online Judge | 1040 Solution | Average 3
- URI Online Judge | 1038 Solution |Snack
- URI Online Judge | 1037 Solution | Interval
- URI Online Judge | 1036 Solution | Bhaskara’s Formula
- URI Online Judge Solution| 1035 Selection Test 1
- URI Online Judge Solution| 1021 Banknotes and Coins
- URI Online Judge Solution| 1020 Age in Days
- URI Online Judge Solution| 1019 Time Conversion
- URI Online Judge Solution| 1018 Banknotes